LastPass 3.3.2 火狐插件弃用计划

 

大约一年半之前,Mozilla 公布了一些即将对火狐插件实施的重大变更。为解决浏览器之间的兼容性问题,火狐及其他浏览器采用了名为 WebExtensions 的通用 API。支持通用的 API 应能够降低我们这类必须为多个浏览器构建、维护扩展的公司的跨平台开发成本。虽然推行 WebExtensions 为开发者、浏览器和用户带来了诸多好处,但我们想确定我们的 LastPass 用户群是否已准备好放弃火狐之前提供的用户体验。

一年多来,我们为火狐维护了两个版本的 LastPass。火狐插件库中仍有 3.x 发布版本,不过 LastPass.com 上已经提供了 4.x 开发人员渠道版。

虽然这让 LastPass 用户感到混乱,但我们维持“旧”版本的原意是为了保证火狐用户能够依然享有他们偏好的本地体验。同时,我们仍然根据 Mozilla 所做的变更继续推行 4.x 版本。但据最近的报道,Mozilla 将在 2017 年年底专门推行 WebExtensions,届时我们将告别火狐 LastPass 3.x 版本。

我们将于 2017 年 3 月 31 日提交最新版扩展,并预计在 Mozilla 审查后的数日内向所有 3.3.2 用户推出。现在,您可以手动升级您的火狐扩展,也可以待 4 月获取自动升级。届时,addons.mozilla.org 和 LastPass.com 上将只有版本 4.x。对于我们的火狐 3.x 版本用户来说,更新后的版本不仅对基础逻辑和性能进行了各种幕后改进,还有我们的最新用户界面。根据之前的用户反馈,我们也建议查看 4.x 界面上的“网格视图”和“列表视图”选项(如下所示),找到适合您的布局。

 

LastPass 3.x Interface

LastPass 4.x Interface

除了与 Mozilla 的变更保持同步外,我们相信,全新的火狐扩展版本能够全面改善我们的用户体验。我们深知改变不易!我们会继续听取您的反馈,致力于实施以数据驱动的智能化变更,同时实现各浏览器和平台的 LastPass 体验的标准化。

当然,这次过渡对您的 LastPass 帐户和您储存于库中的任何信息都没有影响。您仍可使用任何浏览器或您选择使用的设备随时访问您的帐户。

一如既往,如有任何有关过渡的问题或疑虑,您可以联系我们的支持团队